1From 04fa5e1ade08696b5a2cc3b65bf0fd26c43251c7 Mon Sep 17 00:00:00 2001
2From: Sonny Sasaka <sonnysasaka@chromium.org>
3Date: Fri, 19 Mar 2021 11:17:43 -0700
4Subject: [PATCH] common-mk: rebase_path output location of generate-pc.py
5
6Without rebase_path, the generate-pc.py would be called like
7`generate-pc.py --output //out/Release` if the output is inside the
8source directory and this gn path isn't recognized as a generic
9filesystem path.
10
11BUG=b:183216216
12TEST=with modp_b64, call
13$ gn gen out/Release --args=...
14$ ninja
15
16Change-Id: Ic9d9b3d01d52d483e3d81ca2e8d514b47900f5bb
17---
18 common-mk/pkg_config.gni | 2 +-
19 1 file changed, 1 insertion(+), 1 deletion(-)
20
21diff --git a/common-mk/pkg_config.gni b/common-mk/pkg_config.gni
22index 24e2cf1401..b2c58845d4 100644
23--- a/common-mk/pkg_config.gni
24+++ b/common-mk/pkg_config.gni
25@@ -84,7 +84,7 @@ template("generate_pkg_config") {
26     outputs = [ "${target_out_dir}/${output_name}.pc" ]
27
28     script = "//common-mk/generate-pc.py"
29-    args = [ "--output" ] + outputs + [ "--name=" + name ]
30+    args = [ "--output" ] + rebase_path(outputs) + [ "--name=" + name ]
31     if (defined(description)) {
32       args += [ "--description=" + description ]
33     }
34--
352.29.2
36
37